关于WordPress的权限设置

WordPress在更新时有时会出错,多数情况下是文件权限问题。比如

“因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。: wp-admin/includes/update-core.php”即是文件权限的原因。

这里介绍一种方便安全的wordpress文件权限设置方法。

  • 安装wordpress及其更新时:

chown www-data:www-data -R *   # Let Apache be ownerfind .

-type d -exec chmod 755 {} \;   # Change directory permissions rwxr-xr-xfind .

-type f -exec chmod 644 {} \;   # Change file permissions rw-r--r--

  • 安装及更新完成后

chown root:root -R *          # Let your useraccount be owner

chown www-data:www-data -R wp-content # Let apache be owner of wp-content

原因在这里有详细的解释。